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Design and Build a Website Using Dreamweaver MX 200 4 
 

 
Welcome to the Dreamweaver part 2 training sessions. ITI provide this session to help faculty and 

stuff to be able to use an advance software such as Dreamweaver MX 2004 to create their personal, 

class, or department website. 
 

 

In this session you learn how to: 

 

·  Construct the site structure. 

·  Create html pages. 

·  Create template page. 

·  Create tables and cells with different sizes. 

·  Create an editable region. 

·  Insert images. 

·  Insert rollover images. 

·  Add background and borders colors. 

·  Apply a template page to other pages. 

·  Add text to your web pages. 

·  Create internal and external links. 

·  Upload the site files to the server.  

 
 
 
 

Tutorial developed by Savitri Wilder for Information Technology and Instruction 
Central Missouri State University, 2006 
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Constructing the Site Structure 
 
      
NOTE: when creating a website it is important that all files are located in one folder. In that main 
folder can organize your files by creating sub-folders. 
 
 

 
 
 

1. Create a root folder , also called a local site folder . You can name this folder “My Website” or 
something to identify the content. 

 
2. Under this root folder, create three subfolders (make sure they are in small letters). 

a. “html ” – which you will put all of your html files when you create them later 
b. “images ” – which you will put all of your graphics 
c. “pdf ”, “documents”, or whatever you like – which you will put the above type of files into. 
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Getting into Dreamweaver and Setting Up your Site 
 
 

1. Go to Start  > Program  > Macromedia  > Dreamweaver MX 2004 . 
2. Click on the Dreamweaver icon  to start. 
3. In the workspace dialogue box , select Designer. 

 
 
Setting Up your Site 
 

1. Click Site  > Manage Site . 
2. In the Manage Site dialog box , click New. 
3. From the drop-down option, choose Site  
4. In the Site Definition dialog box , click the Advance  tab. 
5. Under Local Info : 

a. In Site name , enter “mysite” or whatever you want to name your site.  
b. In Local root folder , click on the yellow folder  to browse to your local/root folder  you 

created before (Part I – 1). 
c. Click Select . 
d. In the Default images folder, click the yellow folder, and browse to images folder that is 

in the local/root folder.  
e. Click Select . 
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6. Under Remote Info: 
a. Click the drop-down menu next to Access: . 
b. Select FTP. 
c. In the FTP host , type in “cmsu2.cmsu.edu ” 
d. In the Host directory , type in “/public/ ” 
e. For the Login  and Password , enter your CMSU user ID (three letters of your initials 

and the last four digits of your SSN plus “0”) for the login and the password that goes 
with it (birth month and date if you have not changed it, ex. Feb 5 would be 0205). 

f. Click OK > Done. 
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7. Look to the right of Dreamweaver. Under Files  you should see your folders (html, images, etc). 
If you do not, make sure that you are looking at your Local view . 
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Creating Your Site 
 
 
 
 

NOTE: For the purpose of this practice, I have created pre-made images which are located in the 
“images ” folder. The design we are going to work on is sketched below. 
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Creating the index.html page 
 
 
 

a. Under Create New , Click the HTML option. 
 

 
 
 

b. Click File  > Save As . 
c. In the Save in , browse to your local root folder . 
d. Save this file in the “html ” folder as index.html . 
 

 
e. Click Save. 
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         Creating additional HTML files 
 
 

 
a. Follow the index.html direction of creating a new page. 
b. For this class, you need to name your files: about.html, resources.html, schedule.html, 

and contact.html. 
c. Instead of saving the file in the local root folder, you need to Save in  the file in the 

“html ” folder located in the local root folder  (Part I-2). 
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      Creating a Template 
 
 

a. Click File > New 
b. Under General Category  select Template page , then under Template page, select 

HTML template . 
 

 
 
c. Click Create . 
d. After you see the blank document, click File > Save as Template. 
e. A pop-up will show up with a warning. Just click OK. We will fix this later. 
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f. Another pop-up will come up asking for a template name. In here type in a name, for 
example: savitri_template (all lowercase and no spaces). 
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Laying out the template in design mode  
 
 

a. In the Insert Bar , click Common  > Layout . 
 

 
 
b. You will see three options, Standard, Expanded, and Layout. Select Layout . 
c. Before we start, make sure the Properties Inspector is turned on. To turn it on, click 

Windows > Properties. 
d. Click the Draw Layout Table icon.  
 

 
 
e. A pop-up will come up. Click OK. 
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Creating tables and cells  
 
 
 

NOTE: Before we start, I would like to remind you that our goal is to create a site just like 
the sketch above. The specifications are as follows: 

·  750 x 550 Main Table  
·  750 x 116 Title Cell  
·  132 x 434 Button Table  (where the buttons will be) 
·  Five Button Cells , 132x46 (within the Button Table) 
·  618 x 434 Text Cell  

 
 

a. Click on the work area. When you see the “+” sign, hold down the mouse and 
drag the table to 750 x 550 pixels . These numbers will show on the border of the 
table. 

b. If you did not get the size perfectly right, select the table and then go to the 
Properties Inspector under the work area and change the dimension of the table 
manually.  
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c. Now click on the Draw Layout Cell icon  (next to the Layout Table icon). 
d. Click inside the table  where you want to put the cell. Hold down the mouse and 

drag the cell to the size you want.  
e. Again you do not have to be perfect; you can change the size manually by going 

to the Properties Inspector like in step “g” above. 
f. Using the same method, create the rest of the table and cells for the buttons and 

text area (see sketch). See screen shot on next page for the final result. 
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Creating an editable region  
. 

 
a. Select Standard . 

 

 
 
 

b. On the Insert Bar, click Layout  > Common . 
c. Select the area where the text/content will be edited (the 618 x 434 region). 
d. Click Insert  > Template Objects  and select Editable Region . 

 

 
 

e. Name the region something like content, body, text, etc. 
 

 
 

f. Click OK. 
g. Lets Save. 
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Adding the images  
. 
 

a. Place your cursor on the top cell where the banner will be. 
b. Click Insert  > Image. 
c. Browse to choose the image called banner.jpg (it would be in the local root 

folder  under “images” ). 
 

 
 

d. Highlight  the image and click OK. 
e. Click on the image that is now on your page. Go down to the Properties 

Inspector  and type in an Alternate text  (Alt). Keep this Alt tag very brief, for 
example: “CMSU frog exhibit banner”. 

f. You can use this adding images method when adding any image to any of your 
page. 
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Adding rollover images and linking them to the corr ect pages  
. 
 

a. Move your cursor over to the first button cell and click on it. 
b. Click Insert > Image Objects  and select Rollover Image.  

 

 
 

c. An Insert Rollover Image dialog box will come up. 
i. Image name : Type in the name of the image, for example “home” for the 

Home button. 
ii. Original image : Click on the Browse and select the “home.jpg” image file 

located in the “images” folder located in the local root folder.  
iii. Click OK. 
iv. Rollover image : browse to the “images” folder again and select the 

“home_up.jpg” file (all files that have the _up in the file name are the 
rollover images). 

v. Click OK. 
vi. Alternate text : Type in a very brief description of the image, for example: 

“back to first page”. 
vii. When clicked, Go to URL : click browse, go to the local root folder, and 

select the “index.html” file.  
 

 
 

viii. Click OK. 
d. Do step a – c to insert the rest of the rollover buttons (see sketch). 
e. If you miss anything, don’t worry. You can edit all this information in the 

Properties Inspector. 
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Adding background colors 
. 

 
a. Click the cell where you want to add the color. 
b. To add color, you can type in the hexadecimal number  of the color into the Bg 

color  in the Properties Inspector or you can click on the square box  next to Bg 
color and select a color that way. 

  

 
 

c. If you select the second option, you should have a color picker . You can use the 
color picker to choose a color from the palette or you can click anywhere on the 
screen with this color picker and pick the color you want.  

d. For this tutorial, select the same green color as the buttons . 
e. Do the same for the text area, select the cell and color it white or some other 

color. 
f. File  > Save. 
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Borders and background 
. 

 
a. Select the text area cell. 
b. Go to the Properties Inspector  and in Border , type in “1”. 
c. In the Brdr color  (right under Border) select the color you would like this border 

to be. 
d. If you would also like a background color, right click  on an area outside your 

layout table.  
e. Left click on Page Properties . 
f. Find Background color  and select the color you would like for the background 

of the site. 
g. Experiment with all these different options and see which one looks the best. 

 

 
 
 
 
 

 
 
 
 
 
 

Borders Color 
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Applying the template to other pages.  
. 

 
a. Open the file index.html 
b. To the right of your Dreamweaver program, select the Assets (it is under Files ). 

 

 
 

c. Locate the Templates icon  (the second icon from the bottom) and then select it. 
d. With your template highlighted, click the Apply button at the bottom left of the 

window. 
 

 

Templates 
icon 
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e. A dialogue box will come up and you need to select Document body . 
f. In the Move content to new region  dropdown, select “text” or “content” 

(whatever you named the editable region in step 5 (editable region section). 
g. Click OK. 
h. You should see your template in the index.html page. 

 

 
 

 
i. Before we move on, lets Title the page . 
j. If your Document Bar  is not visable, click View > Toolbars  > Document . 
k. In the Title  field, type 2005 Frog Exhibit  (you can replace this with whatever title 

that is applicable to your page). 
 

 
 
 

l. Press Enter  on your keyboard. 
m. Don’t forget to Save. 
n. Do steps a – m for the rest of your pages. 
o.  
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Adding the text  
. 

        
a. From http://www.cmsu.edu/x81239.xml open Body Text  word file under Dreamweaver 

part 2.   
b. Select all the text  and copy it. 
 

 
 
c. Paste the text in the text cell of the index page  of your Dreamweaver website and the 

notice what happen. 
d. Select the text you just basted. 
e. Press (Ctrl +  X) to delete it.  

 
Now lets try adding the text from WordPad or Notepad: 

 
a. Go to Start  > Program  > Accessories  > WordPad 
b. Copy the text in the Body Text file. ( Word)  
c. Paste the text into WordPad 
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d. Now, copy the text from WordPad and paste it into text cell  of your index  

Dreamweaver page. 
 

 
 
e. Notice the difference. 
f. Modify the text using Properties Inspector tools. 
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Creating the links  
. 

 
1. Create internal link: 

 
a. Highlight exhibit schedule  in the second paragraph.. 
b. Go down to the Properties Inspector, and in the link click on the folder icon and select 

schedule  page under html file. 
 

 
 
c. You can also choose any other sources in your local root folder such as images and 

documents.  
 

           2.  Create external link: 
  

a. Highlight Google in the second paragraph. 
b. Go down to the Properties Inspector, and type http://google.com in the Link textarea or 

copy the website address from the website and paste it into the Link textarea. The copy 
and paste method is recommended if the website addr ess is very long .  

 

 

Link 
Textarea
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Preview the pages  
. 
 

a. Press the F12 key. 
b. You can also click File  > Preview in Browser  and select the browser (usually 

iexplorer unless you have more browsers installed). 
c. You can also click the preview icon  (looks like a globe) on the top of the window 
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Uploading Your Files 
. 
 
 
In the Files site window, select all the files you would like to upload. Since this is the first time, you 
would want to select all except for the Template folder. Hold down your CTRL button to select 
multiple items. 
1. Push the blue arrow up  button to put the files up to the remote server. 
2. Open up your Internet browser and go to http://cmsu2.cmsu.edu/~centralID (change centralID 
to your username) to preview the site. 
3. Test your site on multiple browsers  (Netscape, Mozilla, Opera, etc) and if possible multiple 
systems, like on a Macintosh if you built the site on a Windows system. Some browsers and 
systems read HTML sites differently.  
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